Getting started with the Arietta G25 board

This weekend, I received my ACME Arietta G25 Atmel ARM board, and tried to get it going with my Mac. I ordered the “plain” version with 128 MB RAM, as well as one with 256MB RAM, as well as Wifi boards and the DPI debug board.

After soldering in the necessary posts, I attached the DPI board and verified that my Mac has the right FT232 driver to access the console, no problems here.

I then fired up by Ubuntu VirtualBox machine and followed the instructions to build the Micro-SD-Card image. I then proceeded to boot successfully from the card.

IMG_2989

Through the console, I could get the Wifi card going; since I wanted to have support for more than a single network, I extended the configuration through wpa_supplicant.conf.

ACME has configured a Gadget driver to supply an Ethernet interface through the host port on the Arietta; in ACMEs configuration, this is set to offer both RNDIS and CDC EEM modes. Unfortunately, Mac OS X 10.9 doesn’t support either.

After some more reading, I decided to build my own kernel and modules. To get a Mac-compatible setup for the USB Gadget driver, run menuconfig, and navigate to

  • Device Drivers
  • USB support
  • USB Gadget Support (at the very bottom of the list)

For Mac compatibility, de-select the RNDIS support and the Ethernet Emulation Model (EEM) support under Ethernet Gadget.

I also chose to enable the Serial Gadget and the CDC Composite De
vice (Ethernet and ACM).

After building the kernel and replacing the files on the SD Card, I changed the module load line in /etc/network/interfaces to load the g_cdc module instead of the g_ether module, and added an entry in /etc/inittab for /dev/ttyGS0 to also have a console through the host port.

11 thoughts on “Getting started with the Arietta G25 board

  1. Samuele

    Hi thanks for your usefully post. I try to compile at91boot and arietta kernel directly on my macbook without passing from an ubuntu virtual machine. But even if compile myself an arm toolchain I have some error when compile at91bootloader (ld symbols not found on x83_64)… do you know if there is a simple way to compile all of this directly on a macbook?

    Thanks
    Samuele

  2. stb Post author

    I’ve decided to go with a Linux VM for two reasons: there’s enough cookbooks and examples on how to build these kinds of images on Linux. That way, you can follow the instructions exactly, and if anything doesn’t work, there’s a decent chance you find someone who has solved that problem before. Secondly, getting the build toolchain to work on Mac OS X probably is possible, but since so few people do that, and there’s lots and lots of arcane details you have to get right, it’s really hard.

    My ultimate goal is to get FreeBSD running on the Arietta, and I do have a powerful FreeBSD server I can use for cross-building both FreeBSD and packages; I don’t think I’ll try and set up a toolchain on the Mac anytime soon.

  3. Samuele

    Hi thanks to you post, I’ve successfully build a mac-compatibile kernel. I’ve some problems to share the Internet connection between Arietta and the mac via g_cdc. I can ping Arietta from mac and viceversa by when I try the apt-get update I can’t reach the repositories. Are you able to share Internet connection?
    Bye
    Samuele

  4. Samuele

    Yes I tray the internet sharing bit without success…now I’waiting for the WiFi antenna because i’ve bought the WiFi board that require the external antenna but I miss the antenna 🙂

  5. stb Post author

    Hhm, I tried using Internet Sharing, but it’s not working for me either. The quick solution might be to install tinyproxy on your Mac, and point apt at that.

    I also got the Wifi modules that require an antenna, but I can use them even without an antenna; I’m about 15 feet and two brick walls from my wifi router, for what it’s worth.

  6. Samuele

    Wow fantastic!! I configured successfully tiny proxy on my Mac and now I can access apt repos from arietta!
    Regarding the WiFi connection I’m investigating was wrong… like also I don’t understand why the usage of Mac Internet Sharing doesn’t works…

    Bye!

  7. Samuele

    Hi! I have found the problem on connecting arietta via wifi… an error on a key. Now I have the connection available on wireless without antenna 🙂

  8. pihomeserver

    Hello,
    I compiled the kernel, installed it on the SD card but once Arietta connected on the MAC, i can’t ping it
    In the network settings of the mac i have a “CDC Composite Gadget” entry that is created with DHCP as a default value. I activated the Internet Sharing with a bridge between my wifi and the CDC entry.
    Then if i do the ping to 192.168.10.10 i can’t get an answer. The IP address is set to a 169.254.x.x which i can ping but get a connection refused for the SSH command.
    I tried to force all values on the network connection but same result …
    Any advice why i can’t get it ?

  9. Sebastian

    Thanks a lot for this write up! Just successfully connected to my ariettta board 😉

  10. Luis

    Hello, I am moving my code from a raspberry pi to the arietta. I just got one, but have no idea what to do next after I get the sd card loaded. Does anybody have or know about how to access linux??

Leave a Reply

Your email address will not be published.